0

Ragdoll issues with Synty character assets. Head spin like crazy

Sam Leitch 3 months ago in Stats updated 3 months ago 11

On death. They ragdoll, and i get a null reference for inverskinematics, track info, headspeed and untrack?

They just spin non stop. Example below. If anyone has any tips for me would be much appreciated.

NullReferenceException: Object reference not set to an instance of an object
GameCreator.Characters.CharacterHeadTrack+TrackInfo..ctor (GameCreator.Characters.Character character) (at Assets/Plugins/GameCreator/Characters/Mono/Characters/InverseKinematics/CharacterHeadTrack.cs:42)
GameCreator.Characters.CharacterHeadTrack.Awake () (at Assets/Plugins/GameCreator/Characters/Mono/Characters/InverseKinematics/CharacterHeadTrack.cs:125)
UnityEngine.GameObject:AddComponent()
GameCreator.Characters.CharacterAnimator:GetHeadTracker() (at Assets/Plugins/GameCreator/Characters/Mono/Characters/CharacterAnimator.cs:289)
GameCreator.Characters.CharacterAnimator:Update() (at Assets/Plugins/GameCreator/Characters/Mono/Characters/CharacterAnimator.cs:174)

Unity version:
2019.4.1f1
Game Creator version:
1.1.9

which character in specific. I'll take a look If I got that one.

The ModularCharacters from the Hero bundle and the male and female peasants from the fantasy bundle.

The ModularCharacters is my player character, the peasants are on start ragdoll characters for stoy purposes.

I am not getting your problem. I will take another look in the morning. I used the female pesent.

ragdoll worked just fine.

Interesting, i have turned the Smart Head IK off and it looks like the error on the NPCs has stopped, but my character still has this issue.


Ideally i would like to keep my Smart head on my player as i am using hotspots with the head tracking feature. But I can always leave this out. 

Ok I see your problem now you are not using the models. you dragged a character from the scene into the model changer

You should use the character model just delete out of the model the characters you do not want as they are layered on top of each other.

Really going to have to look in the morning. As the first time I imported all worked fine. And now it does not.

Im using the prefabs from the fantasy character asset. and dragging them into the character models drop box on the standard Game creator character.

Should i be doing this differently or is there a way not doing this that may help?

Got it. You should use the fixed scale character in the models folder

Wicked, ill give that a go!