0
By Design

Problem with the "marker" in Unity 2019.4

Steve Nock 2 months ago in Behavior updated by Marti (Lead Developer) 2 months ago 9


This is quite a difficult one to explain.  It took a long time to narrow down what I believe is the issue.

If you watch the video linked you will see the problem:- 

(please note:  The above youtube video is set to unlisted so that no one can see it without a link)

I could not work out if it was a marker issue, or Gaia 2019.  I created a few test platforms to see if I could narrow it down (please note:  It works perfectly in the examples (hide and seek) included with the behaviour module)

My second Gaia 2019 terrain failed in the same way.  It was a simple terrain, moderately flat with no obstacles.  The patrolling character walked on it easily but got stuck at the marker.  I had not used CTS this time, or imported any extra assets (Just Gaia 2019, Game Creator and Behaviour (plus Unity 2019.4.2f1).

I then decided to experiment on what I knew worked.  I loaded up the hide and seek scene from the examples and took out the floor and replaced with a flat terrain object.  It still worked fine.  I added a little gradient under marker 1 on the terrain and it still worked.  I then removed marker 01 and replaced it with a new marker 01 (so it had been created in 2019.4.2f1) and it worked, but there was a difference.  When the character stopped at the new marker 01, he then slid along the terrain for a short distance (I kept the offset on the marker to 0 just like the original marker).  The patrolling character only did this on a marker created in Unity 2019.4.2f1.  The other five markers he stopped on the spot with no sliding.

I think that is what is causing the issue with my patrolling character getting stuck.  Cheers

Unity version:
2019.4.2f1
Game Creator version:
1.1.9
+1

This sometimes happens tome when my Marker is too far above or below the terrain. My understanding is that the Marker has a collider and the Character needs to hit that collider. 

I would try with the Marker just above the terrain and see if there are any differences.

Hi ProfPivec.

I have tried with it above, below, directly on the terrain and about waist height.  Still no luck.  The video example, I should have put on gizmo's to show where the marker was.  It is about waist height on the video.

Have you tried it with IK Foot unchecked. That sometimes causes issues with markers on Terrain.

This is with the marker just above foot level and foot IK turned off.  Still getting stuck.  I moved the marker to a flatter area and no good.  I have installed 2019.3.  I am going to check if this worked on that version as I just recently returned to working on my game (took some time out to brush up on C#).

I would love to have been able to continue working with 2018.4 LTS, but Procedural Worlds (makers of Gaia), upgraded my Gaia to Gaia 2 for unknown reasons (a nice gesture, just caused me problems with a lot of my other assets) and my terrain tool only works now with Unity 2019+.  I prefer to work with LTS versions so really wanted to use 2019.4

Still no luck with this.  Would really appreciate if this could be looked at.  Thanks :)

+2

<SOLVED>

I found out what was causing it.  It was not the marker at all.  On my behaviour task (in the behaviour tree) I had clicked the "use condition" without actually including a condition.  It was also set to fail.  I assume this put it into a never ending loop which caused my character to jerk around on the spot.  Difficult one to track down.

Great that you found the problem. Thank you for sharing the solution.

By Design

Thanks for sharing this. I thought the problem would be the one Paul posted, where the Marker's center was buried inside the terrain, so the feet of the character wouldn't be able to reach it.

Glad you were able to fix it :-)