0
Answered

UI GamePad Navigation Stops working With Game Creator (Works without GC)

robsdroid215 2 months ago in Game Creator updated 2 months ago 3

If I create a blank Unity Project (without Game Creator) 

Then create a simple 'Canvas' with a few 'Buttons'

I can easily use my GamePad to navigate my simple UI.

All works as expected: Standalone Input Module, Button Script Navigation etc...

Now if I create a 'New Project' >>> then add 'Game Creator' >>> then create the same UI... My GamePad will not work.

I tried everything: Navigation = Explicit, First Selected, Creating custom AXIS in the input manager just for UI... then updating the Standalone Input Module in Event System with my custom inputs....


Why does Game Creator not work with GamePad UI the way Standard Unity does? and how can I fix this?

When I say GamePad I am referring to a Controller or Joystick.... 

Unity version:
2019.4.1f1
Game Creator version:
1.1.9
GOOD, I'M SATISFIED

;)

Satisfaction mark by robsdroid215 2 months ago

You can mark this as answered or just delete it... Chalk it up to user error. 

Last night I could reproduce this at will on multiple computers... Today It worked as expected. Maybe I was tired. 

One thing I did do different was, I started a blank project with Unity 2019.3.10f1 then I upgraded it to 2019.4.1f1. 

Answered

Maybe the focus wasn't put on the UI elements. Not sure though. Thanks for circling back though

Apologies I forgot I posted this. This is the same issue I am having from my other post that you are looking into... Focus on Pause Menus. You can delete this post. Thanks