0
Under review

Several types of containers do not work.

markusrgb 4 months ago in Game Creator updated by Marti (Lead Developer) 3 months ago 2

Hello, everyone,

i have tried to create a container that can only hold the type "All/Resources - Wood".

I have duplicated the original container template.

and changed the type in the new wood container to "All/Resources - Wood".


At first I had the problem that all objects with a container used this new "wooden container" and not the "standard container" although it is defined in the settings:


Then I edited the default container (only the text field changed)

After that, the "Standard Container" is now used again for all containers.

If I now create a new container for my stack of wood and try to use the new "wood container", it still doesn't work. Only the "Standard Container" is opened.

the standard container has the type : "Everything".

the wooden container has the type "All/Resources - Wood

The stored item in the container also has the type : "All/Resources - Wood".


Another madness:

when I remove the item from the "wooden container" (so it's empty)

and open it, then the wooden container is displayed .... but afterwards they open all standard objects only the "wooden container" again, although the standard was opened shortly before (inGame).

thanks a lot

Markus

Unity version:
2019.3.11f1
Game Creator version:
1.1.8

Is there already a solution for this?

Under review

I'll open a ticket to take a look at this. So to summarize, when opening a Container with a custom UI (A), if opening another one that should open with a custom UI (B), it still uses the first one. Is that right?