0
Under review

Markers are mixed up when there are many of them

Dornano 3 months ago in Game Creator updated by Marti (Lead Developer) 3 months ago 5

When you put many Markers on gameobjects independent from one another (like a building with a marker in front of each door), I noticed they tend to be mixed up. When I want to open door A, the Player should move to Marker A, but instead he goes to Marker B nearby.

I don't have a 100% reproductible way, I thought it was coming from the door copy/paste, so the pasted object is still linked to the copied object's marker.

But later I found out that this issue is occuring on nearby markers, not especially on one I just copy/pasted. And even if I solved this issue by doing a prefab of my door (with the Marker inside), this issue is still occuring anyway.


Have you ever noticed something wrong with the markers before?

Unity version:
Game Creator version:

I just noticed something. Even when I interact with a gameobject wich doesn't have any marker (just a rotate towards action), the Player still wants to go to a Marker somewhere. Most of the time, the problem is not occuring on the first marker, but he rather tend to go to a Marker I already interacted with before

I found a way to show the thing :

Marker bug.mkv

My door has a marker. When I open the door, the Player goes to the Marker. Good.

Then, inside the room, I want to take a medikit. There is no marker for the medikit, just a "Rotate towards" action linked to the medikit prop. But despite this, the Player is heading to the door marker.

Is this information usefull or not, I don't know, but when I made this video the first time, everything was working the right way. Then for the second try, before opening the door and taking the medikit, I first walked a bit in my level (not triggering doors, just walking), and then it gone wronglike in the video.

Here is the Condition for my door:


And here is the Condition for my medikit:


Under review

I haven't been able to reproduce this. Markers seem to work just fine. Beware that maybe the "Trousse de soin" object is not an empty game object and the origin is set somewhere else. Try choosing the "Pivot" selector tool.

Yeah, I double checked on my side, and the "Rotate towards" or "Go to Marker" Actions are not linked to empty game object, and their locations are properly placed in the world (in pivot or center position, it's the same).

Sorry, I'm trying to find a way to reproduce it, but it's hard...

It seems to occur not on simple scene, but on more heavy projects, within a scene where there are a lot of objects, and a lot of markers. As I noticed once, it seems to occur most when there are many things to load. For me, this issue started when I had something like 10 markers, maybe even less, but many props.

I understand. The amount of Markers shouldn't be a problem though. If you manage to consistently reproduce this, please let me know. I'm working on a tool to make markers more easily debuggeable using gizmos and more visual cues, but it's far from being done.