0
Under review

Module Manager Not Showing Often - Bug

JFB 4 months ago in Game Creator updated by Jon Baxter 3 days ago 7

So, often when I download a new module, the Modul Manager greys out... I have to reinstall Game Creator to fix it.

I recently saw a lot of errors, and I wonder if this may help.

This is one of the many errors I saw.

NullReferenceException: Object reference not set to an instance of an object
GameCreator.ModuleManager.ModuleManager.LoadProjectModules () (at Assets/Plugins/GameCreator/Modules/Editor/ModuleManager.cs:222)
GameCreator.ModuleManager.ModuleManager.InitializeData () (at Assets/Plugins/GameCreator/Modules/Editor/ModuleManager.cs:213)
GameCreator.ModuleManager.ModuleManager.GetProjectManifests () (at Assets/Plugins/GameCreator/Modules/Editor/ModuleManager.cs:80)
GameCreator.ModuleManager.ModuleManagerSidebar.PaintSidebarProjects () (at Assets/Plugins/GameCreator/Modules/Editor/Extensions/ModuleManagerSidebar.cs:64)
GameCreator.ModuleManager.ModuleManagerWindow.PaintSidebar () (at Assets/Plugins/GameCreator/Modules/Editor/Extensions/ModuleManagerWindow.cs:109)
GameCreator.ModuleManager.ModuleManagerWindow.OnGUI () (at Assets/Plugins/GameCreator/Modules/Editor/Extensions/ModuleManagerWindow.cs:89)
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <437ba245d8404784b9fbab9b439ac908>:0)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <437ba245d8404784b9fbab9b439ac908>:0)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at <437ba245d8404784b9fbab9b439ac908>:0)
UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at :0)
UnityEditor.HostView.Invoke (System.String methodName) (at :0)
UnityEditor.HostView.OldOnGUI () (at :0)
UnityEngine.UIElements.IMGUIContainer.DoOnGUI (UnityEngine.Event evt, UnityEngine.Matrix4x4 parentTransform, UnityEngine.Rect clippingRect, System.Boolean isComputingLayout, UnityEngine.Rect layoutSize, System.Action onGUIHandler, System.Boolean canAffectFocus) (at <78b213560771414e9fa6f1b95f5ad8bb>:0)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Unity version:
2019.4.0f1
Game Creator version:
1.1.8
Under review

Does this happen only in 2019.4 LTS? Or has happened before? I wasn't aware of this issue. Nonetheless, I'll take a look.

Hi. Yes. It's happened in even previous versions.

It's quite annoying because I am always deleting and reinstalling game creator and the modules.

After taking a deep look at it, looks like you're deleting the project manifest file. These are required in order to keep track of the project's modules. Another cause may be if you're moving folders inside the Plugins/ root folder. Game Creator requires all files to be where they are first installed.

If that's not the case, could you tell us at which point these errors start appearing? This will help us narrow down the search.

Hi. 

They started when I first installed the behavior module. As the behavior module froze Unity and crashed it, I tried manually deleting the Game Creator files from the plugins folder and reinstalling it. That worked and got the game back running.

But ever since then, I've noticed the issue with the module window.

I'm currently having a similar issue. Module Manager is completely missing from the dropdown menu. I started a brand new project yesterday with Unity 2019.4.4f1 and installed only the Game Creator Asset and Stats asset. The module manager was showing and worked as normal. Today, I opened Unity and now the Module Manager is missing. I've reinstalled, checked for update, and opened the Plugins->GameCreatorUpdate->Data->Package file. How can I get it back when this happens?

Hey Jon, do you have any compilation errors in the console? Any scripts that don't compile can influence the behavior. 

Yes, I think that fixed it. It was Unity's standard asset. In the project window, Assets -> Standard Assets -> Utility -> SimpleActivatorMenu script. I deleted that script and reloaded my project. I must have forgotten that I had the standard assets in my project. Thank you!

It's worth noting that when I had this bug, the Module Manager (Ctrl+Alt+M on windows) and Prefences (Ctrl+Alt+K on windows) shortcuts did not work.