+1
Planned

When i shoot, only one bullet is fired after that the event gets stuck

Rahul 4 months ago in Shooter updated by Marti (Lead Developer) 4 months ago 5

When i try to shoot an arrow, after shooting once, the event gets stuck.

I have the events for ammo where i give the player sufficient amount of ammo.

i am clearly doing something wrong here since the example scripts run just fine.

Can any one help to know the problem ?

The character player single shoot remains selected as below and if i click on play icon beside add action, it executes and i am able to shoot 1 more bullet.

Unity version:
Game Creator version:
Under review

After taking a look at the code, I'm not sure what could the problem be. The only time the Action should be put on hold like that is when a weapon is burst-shooting. However, it's not the case in your example.

I'm opening a ticket and see where the problem can be in more depth. However, meanwhile, can you make sure you're using the latest update?

Also, a Bow requires to charge up the shot before releasing it. I'm making an educated guess here, but could you replace this with the following trio of actions?

- Start Charged Shot

- Wait 1 second

- Execute Charged Shot


Let me know how this goes!

The same thing is happening to me. I have a custom model for the gun, but do have archery animations on a character state. Could this be what is affecting it?

So Marti, i tried reproducing the above issue, and it seems that when i change the default prefab that comes with shooter module for bow, this issue happens.

Further more, i tried comparing the prefabs and the default bow prefab for GC comes with a muzzle included in it, i have not included muzzle in my bow prefab. Do you think this might be the issue ? Cause if i use the default bow in my game it works fine but when i try to change the prefab, this issue occurs.

It appears that the muzzle component is required for all weapon types whether grenade, bow, etc. as it is used to determine the starting point of the shot, trajectory and other calculations, usually if there is no "muzzle" component an error is printed to the console stating a script is trying to access that component.


Have you tried adding this to your bow prefab? 

+1
Planned

Yup, that's the issue. A weapon requires the Muzzle Component. I'm not sure why the error doesn't tell that. I'll make sure to include a more self-explanatory error in the next update.