+1
Answered

Feet Not Touching Ground

Crispy 11 months ago in Game Creator updated by robsdroid215 2 months ago 8 1 duplicate

I played around with the Height and Center values but could not get the feet to touch the ground. I think it depends on the model, since it's fine for the default GC model. I know you have a few Synty assets. Could you do a test?

Unity version:
2018.4.8f1
Game Creator version:
0.9.9

Answer

Answer
Answered

As you say, this depends on the 3D model. You can either change the Height of the height of the Character Controller component or open the character in Blender and change the origin of the 3D model and set it a bit higher (around the belly button).

GOOD, I'M SATISFIED
Satisfaction mark by Crispy 10 months ago

Duplicates 1

Answer
Answered

As you say, this depends on the 3D model. You can either change the Height of the height of the Character Controller component or open the character in Blender and change the origin of the 3D model and set it a bit higher (around the belly button).

Like I said, changing the height did not work for me. I asked you to try it because you also have this asset. I don't think it makes sense to have to change the origin of the character, as I've never had a problem with Synty's assets before in other controllers, and I have many many characters I'd have to edit.

The solution is actually to lower the character's Root position within the Avatar panel.

Which is the same as changing the origin in Blender or any other 3D program in the vertical axis. Glad you figure it out.

Thanks this works well for my Synty Model, and there was no need for Blender.

I am going to put some screenshots below so Noobs like me can do it.

Note:

(I did notice when I call up my 'Pause Menu' with 'Change Time Scale' that the Characters legs, from his knees to his feet, straighten out, and go beneath the floor slightly. only on the 'Pause Menu', everything else works fine)

1) Highlight your Character Model in the Project Panel

2) Click on Animator > Avatar > CharactersAvatar 

1) Click on the Highlighted Yellow Character Avatar

1) Click the 'Configure Avatar' button



1) Highlight your Characters 'Root'

2) Make sure you have the 'Move Tool' selected

3) Use the 'Green Arrow' of the move tool to slightly move your Character down

4) Click the 'Done' Button

Also here is a quick 6 minute video that explains Animation re-targeting.

I'm struggling with the same issue. Could you tell me how to adjust the Root position within the Avatar panel, nothing i've tried is working?

+1

i've had the same issue and got it down to 2 issues.

1) messing with the center and height of the character controller

2) messing with this:


try messing with these options especially the bake into pose and offset (Y)

also try to adjust height and center of the character controller during play and see how that affects things.

hope it helps!

Ryubi, can't tell you how much I appreciate that. Many many thanks.