0
Under review

Camera Doesn't Teleport With Player

Matthew Bockholt 4 months ago in Game Creator updated by Marti (Lead Developer) 4 months ago 1

I'm not sure this is a bug, per se, but I find it very annoying. Perhaps it should go under "Ideas" but I'm putting it here because it doesn't seem right to me.

When using the "Teleport Player" Action, the camera (unless in First Person) does not teleport with the player but instead moves (very swiftly, I'll grant) to the new location of the player. This is not ideal, as it means that the camera will move through whatever obstacles are in the way, including buildings and terrain.


I've tried teleporting the camera with the player, but it doesn't seem to work. I'm guessing because the motor is overriding the teleport. I've even tried deactivating the Camera Motor, then teleporting the camera, and then activating the Camera Motor, but this doesn't work either. The camera still won't teleport, even with the motor turned off. Perhaps because of additional scripts attached to the camera object by GC? I don't know, but it doesn't work.


If you want to leave this as "by design" then I would at least suggest a toggle option on the Teleport Player action to "Teleport Camera with Player".

Thanks!

Unity version:
2019.3.13f1
Game Creator version:
1.1.8
Under review

Although I understand your point, I believe the default behavior should be as it is at the moment. However, maybe I could add an Action that refreshes the state of the camera to match the one of the motor so it doesn't lag behind. I'm opening a ticket and assess this. 


I'll circle back when I work on a core update and got some news. Cheers!