0
Not a bug

Input Field - turn off navigation - not working

SteedMaker 4 months ago in Game Creator updated by Marti (Lead Developer) 4 months ago 1

Not sure if this a Game Creator issue or a Unity issue but I cannot turn off the navigational keys while the user is entering text in Input Field (that will go into a Variable using Game Creator).  For instance, if you type an "s" or an "a" the letter is entered into the field but the camera moves according to those keys' navigation instructions.  I have gone into the component and turned Navigation to None but with no effect. This is on my Mac.  Any suggestions?

Unity version:
2019.3.15f1
Game Creator version:
1.1.8
GOOD, I'M SATISFIED

Thanks for info - it works.

Satisfaction mark by SteedMaker 3 months ago
Not a bug

I believe you're looking to change the "Is Controllable" property of a character. You can disable character movement using the Character Property action and the "Is Controllable" option to false.

When you have finished inputing the text Field, you can use the same Action to restore the character movement.