0
Not a bug

FPS weapon aim pitch and rotation issue

Ernst 4 months ago in Shooter updated by Marti (Lead Developer) 3 months ago 7

Hello! I'm having an issue on play mode with the camera pitch when using the FPS character. When the camera looks above a certain angle the weapon seems to loose information about where it is anchored to and starts a random rotation (I'll put a video reference).


The strange part is that this random rotation stops when the character is on sight on the editor window. I have tried installing the Shooter module on another empty project but it is the same. It also happens on the example scenes.

GAME-CREATOR-SHOOTER-ISSUE

Unity version:
2019.3.0f3
Game Creator version:
1.1.8
GOOD, I'M SATISFIED
Satisfaction mark by Ernst 3 months ago
+1
Under review

Hmm this is the first time I see this issue. Can you post a video of the scene view? It's hard to tell what's happening from a first person perspective. You can point towards the character in the scene view and record it from there, I might be able to identify the issue.

It is hard to tell what's going on. As you can see, whenever the player is on the scene view the weapon returns to the correct place. Thanks for taking a look at it.


 GAME-CREATOR-SHOOTER-ISSUE-2

+1

Well.. That video doesn't help much, since every time you move the camera, what's important is outside the frustum of the scene view ^^'

Could you re-record it changing how the FPS camera moves? For example, using the mouse movement, without having to right-click drag.

I think I'm not understanding it right. I'm already using the mouse movement for the FPS camera.
The thing is that I can't manage to capture what is going on on the scene view because it seems that this issue only happens when it is outside of the fustrum (and looking above a certain angle). While in game it is the same, unless you are inside the scene view fustrum.


It is starting to become a serious problem for development since I can't aim at high targets.

+2

If it's a problem with animation culling you can easily fix it selecting the Player character, expanding it and selecting its first child. You'll see there's an Animator component and one of the options is "Culling Mode". Change this to "Always Animate" and see if this solves the problem.

I haven't been able to reproduce this on our end, so we're just guessing what may be wrong.

+1

That completely fixed it. Can't believe I overlooked that. Thank you very much. And by the way, great product and support, glad I went for Game Creator!

+1
Not a bug

Awesome! Happy to hear that :-) Cheers!