+2
Fixed

Melee Combo creator is broken

YeetLordSupreme 5 months ago in Melee updated by Marti (Lead Developer) 4 months ago 5

Fairly simple and easy to reproduce.  In the combo creator you cannot select any button other than "A".  You can click on the "A" button, and the dropdown list showing other keys does appear, however no matter what you click, it will not change from "A".  

I tried manually editing the weapon file with a text editor, but since I couldn't figure out what value the other keys were, I only managed to turn it into a "-1" combo, lol.

Unity version:
Game Creator version:
1.18
Under review

This is something that seems to only happen wit Unity 2019.3 onwards. We're currently officially supporting Unity 2018.4 LTS, which is the most stable version at this moment.

Could you try downgrading your Unity version? We're looking into it but since it only happens on a tech-stream version, it's not high priority.

Yeah, that seems to be the problem.  Thanks for the tip.  I was able to get around it by making a project in 2018.4, and using that to find out what the values were for the other keys in the .asset file.  I then manually edited my .asset file in the 2019 project...and it works!  I still can't change the combos in the editor, of course.  But now at least I can actually use the other keys without downgrading the entire project.

I think I may have solved this problem,Please try to replace this fileComboPD.cs  :Assets\Plugins\GameCreator\Melee\Editor\Classes

Hi Xzm, thanks for the file. I'll check it out as soon as I can!

+1
Fixed

I'm closing this thread as the upcoming version will have the fix. If after updating you still experience issues, feel free to continue the discussion below.

On a side note, I think Unity 2019.4 works fine regardless of the bug patch. Cheers!