0
Answered

Changing character model not working correctly

Bruv 5 months ago in Melee updated by Marti (Lead Developer) 4 months ago 8

When I try to change the standard character in your Melee Example for a Synty model, it changes ok but when I press play the new Player draws an "invisible" sword. The animation is there but the sword model and the "slash" FX can't be seen. I can fight the Enemy character and do damage but the sword model is nowhere to be seen. I've checked all the details as best I can and I haven't changed anything except the model. What am I doing wrong?

Unity version:
2020.1.0b8
Game Creator version:
1.1.8
GOOD, I'M SATISFIED
Satisfaction mark by Bruv 4 months ago

I had a similar issue when I change Character mid fight, after pausing the game. The new character does not have the weapon. However, if you then unsheathe the weapon or retarget the enemy, the sword appears.

Hope this helps.

Thanks for the suggestion but I tried re-doing the unsheathe triggers and actions but nothing worked. It seems to be a problem between the Game Creator standard character, and the Synty low poly character I'm using. They don't seem to be compatible somehow. Synty is a very popular model producer so I don't know why the problem is there. If I swap the GC Player character for the Synty character, everything works except for the sword and the FX not showing. If I then swap the Synty Player BACK to the GC character - it all works again! Could it be the model hand positions being out of sync? If so, I have no idea how to fix that and it would be a major problem for me. This has got me totally baffled.

I just did a test with a Synth Character, my sword appeared but is positioned all wrong.  Your sword is possible there, but somewhere else in the scene. Press pause and search for it and see if you can see it. 

If you are going to mix and match other characters with Synth, you will need to create different weapons for each and reposition them. If you are just using Synty, reposition your weapon in the Weapon Model section of the SwordWeapon component. There is a section in the docs that talks about this.

I eventually figured it out. I was using one of the scaled/multiple Synty character prefabs where you deactivate the bits you don't want. I was dumb enough to also deactivate the Root structure which of course deactivated anything connected to the bones. Ah well, I won't do that again. As you said, the sword is in the wrong position. The character is holding it like a stabbing dagger! I've now got to work out how to reposition weapons. Thank you so much for your guidance, ProfPivec. Much appreciated.

You are Welcome. The GC Community is a good one. Lots of experience and helpful advice. And you can always buy my modules to make your game extra special ;)

Cheers, glad you sorted it.

Oh Wow! Pivec Labs! Yes, I've already got your UI module. It looks really good. I managed to sort out the weapon position thing. It wasn't as hard as I thought. Anyway, thank you, and I'll get on with my project now. (Until I stuff something else up, then I'll be back :)

+1

No worries. I have a new Action Pack waiting to be approved. Has some really cool and useful Actions, like moving platforms and random Actions.

+1
Answered

I'm marking this as answered then. If there are any other issues, feel free to reopen the thread.