0
Planned

Hotspot headtrack

Einar 5 months ago in Game Creator updated by Marti (Lead Developer) 4 months ago 3

Hi,

I've experienced a few issues with the hotspot headtrack, at least one of which seems to be a bug:

  1. The sphere collider used for the head track is on the "water"-layer. This does not play well with other assets.
  2. Hotspot headtrack is active, even if Head IK is turned off on the player/character. This might be by design, but seems counterintuitive.
  3. Distance measured for hotspots seems to follow different rules than distance set for a trigger. Basically, the hotspot/head track is visible before you can actually activate the trigger, even if the distances set on the trigger and the hotspots are the same. For instance, I experience this on hotspots/triggers that are about one unit above ground.

Cheers,

Einar

Unity version:
2018.4 LTS
Game Creator version:
1.1.8
Planned

I'm not sure what's the use case for water layer, but you'll need to check the collision matrix in the Unity Physics settings.


The fact that the Hotspot Head Track works with a character with disabled Head IK is indeed something that shouldn't be happening. I'm opening a ticket to have this fixed.

Yes, this is something we're aware. It's by design, although counter intuitive. Trigger's colliders use Unity physics, which get triggered as soon as the bounding of the character touches the collision sphere. However, the head track is measured using a distance to the center of the character. The difference is in the character's capsule radius.

Thanks!

The thing with the hotspot layer is that the HPProximity-object is put on the Ignore Raycast layer, but the HPHeadTrack-object is put on the water-layer. Looking at the code, it seems there is a legacy-glitch or something in Unity. In HPProximity you do this:

  gameObject.layer = LayerMask.NameToLayer("Ignore Raycast");


while in HPHeadTrack you do this:

  gameObject.layer = Physics.IgnoreRaycastLayer;

The first one puts it on layer 2 (the correct layer), the second one puts it on layer 4 (the water layer). My guess is that this is not intended.

Most likely. The Hotspot system hasn't received much love for the past years. I'll update the ticket with this information. As always, thanks!