0
Fixed

Character wont Stop Spinning

Yair Ciriaco 5 months ago in Shooter updated by Marti (Lead Developer) 5 months ago 3

Hello, Just Bought Game creator and a bunch of other modules, is looking great so far! I have a problem in the shooter module, if in State aiming I change lower body rotation variable to other than 0 the character starts spinning out of control the greater the value the faster the spinning is there a way to prevent this? the aiming animations don't look good if i cant freely use this variable, thanks!!

Unity version:
2019.3.9
Game Creator version:
1.1.6
+1

I already figured it out, is because I'm using the root motion movement action from the game creator hub, when I'm turn off the root motion movement the character stops spinning!

Planned

Excellent! Yes, that might be the issue.

However, since we don't support root-motion, we could easily unmark internally the "use root-motion" checkbox, so you don't have to worry about this anymore.

I'm leaving this thread as Planned and we'll address this for the next update. Cheers!

Fixed

I'm closing this ticket, since this has been internally addressed and will be available with the next update. All animators will default to "no root-motion" when starting the game by default. Cheers!