+1
Under review

Adventure Camera issue Camera Wall avoid?

fred.Man 7 months ago in Game Creator updated by JuliaK 3 weeks ago 9

Somehow the wall clipping does not work for me. That's why i deleted my old adventure camera motor and created about 4 new adventure motors without result. At the fifth try I only changed the wall clip radius to 0.1 and could prevent the wall clipping in parts. But after I adjusted the remaining parameters it didn't work anymore. 

Does anyone know what could be the reason? ;)

Unity version:
2019.2.19f1
Game Creator version:
1.1.5
Under review

Make sure your walls have colliders. Otherwise, the camera won't know where to avoid clipping through. If you already have colliders, also make sure the Adventure Camera has the Layer Mask set to Everything or at least, collides with walls.

Hope this helps!

Hello and thanks for the feedback.

The points listed have been active since the beginning. In the attached graphic, you can see the current configuration where wall clipping of the camera is not prevented. The zoom section has been completely disabled because - from my point of view - it was only active when the character was shooting with a gun.
All building elements are located in the "Stage" layer. The character stands in front of the wall (simple box collider) and is stopped. If the camera is turned, it cuts through the wall.



I believe this is most likely due to the fact that the Pivot Offset's Z is set to 1.3. Try setting this to zero.

I have the same problem. Colliders work for the player. But not for Adventure Cam. Even the  Pivot Offset's Z is not set to 1.3 does not change it. A little bit changed by playing around with the Main Camera Settings. But it's not 100% solving the problem.

Create a few spheres with triggers around your players head and make them a child of the player. Make sure the mask ignores everything but walls. When one enters a wall set the target to a different sphere. When your "preferred" collider exits a collision, set it as  your target again. 

Also Keep in mind that the wall avoidance uses your zoom settings, even if zoom is disabled.

Same problem. It seems that the system supports the box collider but not the mesh collider. It forces you to add empty boxes with box colliders on the walls, which is not ideal.

Would it be possible to fix this very annoying problem.

In order to check collision against obstacles, we need to make use of the physics "world". Checking against geometry would drain performance and would come with some serious side-effects problems.

Plus, using layer masks can really improve performance and allow you to decide which objects should the camera take into account when avoiding clipping through.


Could you explain the use of layer mask ? 
Or, is there any documentation on this?