0
Answered

"On Mous Left Click "with "ignore collider with tag xy"?

markusrgb 8 months ago in Game Creator updated by Marti (Lead Developer) 8 months ago 1

Hello, everybody,



I use the trigger "On Mous Left Click" for objects in houses to trigger various actions. But it happens, that there is another collider in front of the "Click Object", which must remain active.
But then clicking on it does not work anymore.
Is there a way to use an "ignore collider with tag xy"?

Thanks a lot

Markus

Unity version:
2019.2.18f1
Game Creator version:
1.1.5
GOOD, I'M SATISFIED

super thanks, that helped me a lot. :)

Satisfaction mark by markusrgb 5 months ago
Answered

Not with tags, but with Layers. Layers are on the right side of where you select the Tag on an object and allows to do exactly that. 

A quick and dirty way to solve this is setting up the bigger collider in the "Ignore Raycast" layer, which by default is ignored by the physics engine.