+1
Not a bug

NavMesh agent inactive by default, model wont detect navmesh terrain or objects.

Andi Rutz 8 months ago in Game Creator updated by Marti (Lead Developer) 6 months ago 6

Can someone please help me with a navmesh issue? I set the ai to wander around but it doesn't use the navmesh agent. It has the checked box and when it spawns it has the agent script but its unchecked. And I cannot check it unless I uncheck Character Script. Thanks In advance!

Unity version:
2018.4.7f1 and newest 2.0
Game Creator version:
9.9...

Answer

Answer
Not a bug

Hi Andi. The Navigation Agent is disabled due to the Character being told to use the Character Controller instead of the Navigation Mesh. Let me explain this a bit.

Game Creator has two different controller systems: Character Controller for directional and standard movement, and Navigation Agent when traversing the environment with a target in mind.

We swap between these at runtime, so if the Character Controller system is running, we disable the Navigation Mesh Agent component. That's why you can't enable the Agent, because the Character system is using the Character Controller.

The wander script is made by a community member of Game Creator and he's probably using the Directional movement, instead of picking a random position of the map (which I believe it's fine, otherwise, you'd have to deal with edge cases, like trying to wander outside of the map's bounds and so on).

Try reaching him out. He may be willing to update the script in the Hub to support Navigation Mesh Agent.

Hi Andi. The NavMesh Agent is automatically enabled when required. If you have correctly set up a Navigation Mesh, make sure also you check the "can Use Navmesh" option under Advanced Properties in the Character's Inspector (see this link for some screenshots: https://docs.gamecreator.io/game-creator/game-creator/characters#advanced-properties

yes this option is checked, nav mesh is baked the issue is work the wander script on the hub site. It seems to work fine when using move to position but when i try the wander action it automatically ads nav mesh agent but its unchecked and it does not allow me to check it unless the character script is disabled. 

+1
Under review

Not sure where the problem is then. That script was created by another user although I don't think the problem is in the script. Could you attach some more screenshots or video capture? More precisely the entire Character inspector and how it behaves

I tried using this again and still getting the same issue. https://www.loom.com/share/51d6c11f3cb24ab996f20fb354889305

Answer
Not a bug

Hi Andi. The Navigation Agent is disabled due to the Character being told to use the Character Controller instead of the Navigation Mesh. Let me explain this a bit.

Game Creator has two different controller systems: Character Controller for directional and standard movement, and Navigation Agent when traversing the environment with a target in mind.

We swap between these at runtime, so if the Character Controller system is running, we disable the Navigation Mesh Agent component. That's why you can't enable the Agent, because the Character system is using the Character Controller.

The wander script is made by a community member of Game Creator and he's probably using the Directional movement, instead of picking a random position of the map (which I believe it's fine, otherwise, you'd have to deal with edge cases, like trying to wander outside of the map's bounds and so on).

Try reaching him out. He may be willing to update the script in the Hub to support Navigation Mesh Agent.