0
Under review

Custom made animations dont play right with gestures

radicalradish55 3 weeks ago in Game Creator updated by Marti (Lead Developer) 3 weeks ago 3

anim_error.mp4

basically custom made animations, no matter what rig or what tool or what export used (i used the game creator character and did the animation in umotion just to check) it would play the animation really choppy and start several frames in basically only playing like half the animation (using play gesture)

i tried with umotion, blender, exporting with different fbx types and settings, exporting as clip and fbx with umotion, 

as well as ticking literally every option available with the animation import window etc


non custom animations and mixamo ones worked but self made and self keyed ones didnt.

also tried several different keyframing methods like rotation / whole character and such. 

i posted this wayyy back in the discord and got ignored so the memory is hazy but i remember trying all kinds of things and different methods for a couple of days straight. 


since it put my project on a dead hold, i stopped using game creator and switched to playmaker. it works perfectly now, i use the unity animator for playing the animation now and have no issues. so im confident that its a gestures issue.

heres the action btw

https://cdn.discordapp.com/attachments/367737057126252545/652337931150950420/action.png

Unity version:
2019.2.5f1
Game Creator version:
1.0.7
+1

Gestures and States was rebuilt in 1.1.1, you are still using 1.0.7? 

Also, your Swing Overhead animation starts from a drastically different pose than your Walk animation. Unity's Blend Trees can only do so much, especially if they aren't really being applied correctly. Also,strange things can happen when you are playing an animation at a quarter speed of the original (why do this?) 

"non custom animations and mixamo ones worked but self made and self keyed ones didn't."

^^That should be a pretty big clue that Game Creator isn't the primary culprit (even if Gestures and States were overhauled in more recent versions than the one you are using). 

it felt like a game creator issue to me because it works perfectly with the unity animator and after switching from gc i had no such issues. because of that i figured the animation starting in a drastically different pose than the previous one shouldnt be an issue and if it is its a game creator / gestures related one and not an issue with the animation / blend trees themself because they work perfectly when im not using gestures.


i was playing at quarter speed to show the issue in more detail. at full speed its the same issue just harder to notice because of how quick it is. 

i was using 1.0.7 because i had this issue a few weeks back. didnt know gestures were rebuilt so ill try that later.

Under review

Let me know if the new system fixes the issue. However, I'm skeptical that it will, since it' been rebuild to add new features and improve performance, not because the old one wasn't working correctly.

Another thing that might be causing the issue is the AvatarMask you're using. Could you try without it?