0
Not a bug

Stats missing from Preferences

Crispy 3 weeks ago in Game Creator updated by Marti (Lead Developer) 1 week ago 5

After importing and enabling the Stats module, the "Stats" section was not in Preferences. But it appeared after enabling Stats Examples. This is not due to the new update, because I had this problem before. Disabling Stats Examples causes the "Stats" section in Preferences to disappear. Today, after updating Stats Examples, everything under the "Stats" section was reset.

Another minor but annoying thing is this: https://streamable.com/0cs22

The same happens with Actions: https://streamable.com/lbepn

Unity version:
2018.4.11f1
Game Creator version:
1.0.4

Answer

+1
Answer
Not a bug

There seems to be a bug on Unity's asset database end that they are aware of but marked as Won't Fix (see https://issuetracker.unity3d.com/issues/assetdatabase-dot-findassets-t-locale-returns-empty-list). There's little we can do on our end.

However, @Necka user from the Discord server helped us (well, he did all the heavy work) and discovered that right clicking on the Plugins/GameCreatorData folder and selecting Reimport fixes the issue.

Not a bug

Enabling and disabling Example scenes will always overwrite your preferences. If a section disappears after uninstalling an example modules, try closing and opening Unity.

As for the text field properties keeping the previous text, this is something on the Unity side. I believe this behavior is intentional in case you want to keep a value between play-mode and editor-mode.

"After importing and enabling the Stats module, the 'Stats' section was not in Preferences."

https://streamable.com/egbhm

Maybe it's because I enabled the Shooter module first.

Under review

Have you tried restarting Unity? Does it appear then?

Nope. Using 2018.4.11f1.

+1
Answer
Not a bug

There seems to be a bug on Unity's asset database end that they are aware of but marked as Won't Fix (see https://issuetracker.unity3d.com/issues/assetdatabase-dot-findassets-t-locale-returns-empty-list). There's little we can do on our end.

However, @Necka user from the Discord server helped us (well, he did all the heavy work) and discovered that right clicking on the Plugins/GameCreatorData folder and selecting Reimport fixes the issue.