0

Help changing IsGrounded anim parameter to 1 in played locomotion.

Seth Fillmore 1 month ago in Game Creator updated by JSonMac 1 month ago 1

As stated in the subject I'm attempting to manually set IsGrounded to 1 on the player animator to get overriding animations on state locomotion to properly work while swimming (actually if i can get this to work i'll just create a blend tree in the animator itself for swimming). But I can't for the life of me get it to work. I've tried every combination I can think of. I've tried all Trigger, Condition and Action all on the object that gets the animator. I've tried it as children of the gameobject, a mix. I've tried invoker, player, gameobject.  Nothing works on it. Its getting triggers just not changing the parameter. Pretty lost at this point so any help would be greatly appreciated.

Unity version:
2019.4.10f1
Game Creator version:

I think I already posted a answer to you in other topic. One thing: are you using GC Locomotion States? I'm asking because if you use it there's no need to set the animatir trigger and probably will work as I described in the other post.