0

I want to know how to set the animator parameters, you can see my screenshots, I need help.

cloud cang 3 weeks ago in Game Creator updated by BV123 2 weeks ago 8

我想知道如何设置动画或参数。

Unity version:
2019.4.8
Game Creator version:
1.1.9

I tried a lot of methods, but the robot animation still did not play, I do not know where the operation is wrong?

Did you click on the arrow between a4IdlePose and a5WalkCycle and set up the run trigger as a condition?

Also, I noticed that you're using Behavior. Did you add a Behavior component to your robot?

Yes, I have set "run" as the trigger condition. I play the animation in the behavior tree. I have added a behavior component, but the robot doesn't play the animation. I don't know what I did wrong. Maybe this is a bug in GC.

+1

Ok, try this:

1) In your behavior graph, create a blackboard Game Object named Animator

2) In the Behavior Component on your robot add the robot object that has the Animator Component to the Animator Parameter.

3) In the Animate Action in your behavior graph set it to Local Variable, Invoker, Animator, run. 

I just tried this and it worked for me. Hopefully, that helps. 😊

if the problem is still there, it may be a problem with the animation file. 

In the Animator Window right-click on a5WalkCycle and choose Set as Layer Default State and test play. If it still doesn't animate then you know that's where the problem is.

Yes, he works, thank you for your help, you helped me a lot.

Glad to help 👍