+1
Planned

Top down shooter Character is aiming up towards the sky at some spots of the map

Samuli Jolkio 2 months ago in Shooter updated by Marti (Lead Developer) 4 weeks ago 9 1 duplicate


At some points of my map, my character starts randomly aiming up. A whole map is just a big plane and there shouldn't be anything weird going on in terms of that. I'm using "Aim Top-Down Plane" for aiming, and it mostly works fine except for these few random spots. Any idea what could be going on?

Unity version:
2019.4.4f1
Game Creator version:
1.19

Duplicates 1

These are the coordinates for where this happens: X = 35.74797 Y = 0.07999978 Z= -35.74797. And the aim is at NorthWest.

Same thing seems to happen with the Top-Down example scene if you extend the floor to cover a wider area.

There seems to be an invisible plane that has a size of about 80x80 and at each corner of it player starts aiming up if you aim at the center of the plain.

Under review

I've tried reproducing this and haven't been able to. Can you provide more info? Showing for example the current hierarchy (see if there's anything with an invisible collider) or try it in a brand new scene with just the floor and the player.

Also, can you tell a bit more about the camera? Is it fixed or can it move around?

Here's how I can reproduce it. 
- Open Exmple3-Topdown
- Remove the original floor from the scene and replace it with a plane that is scaled x=80 z=80
- Move your character to position x = 35 y = 0 Z = -35
- Start the game, equip a weapon and aim towards North-West.

it only happens after the action reload and aim

I tried to stop aiming -> reload -> aim, but it's still happening.

When the character pickup a gun, I have an aim action that the character will be aiming after draw the gun.

It has no problem until I try to reload, then the reload action is stop aiming -> reload -> aim. And this look upward thing happens.

Just tested in more detail, it looks like only happen when the ammo is a projectile type.

Here is the video, I switch between 2 weapons with 2 types of ammo, only the projectile type causes this problem

+1
Planned

Hmm definitely looks like something fishy is happening here. I've opened a ticket and I'll take a thorough look at this and circle back as soon as possible!